PDA

View Full Version : Magnavox Odyssey -- sweet torture



zmeston
03-29-2003, 03:40 PM
So I sold my left lung (I work inside all day, I'm not athletic, I'm a shallow breather -- an easy decision) and picked up a 1972 Magnavox Odyssey, still in the box (!)... but untested.

I plug cartridge 1 into the Odyssey -- the paddles appear, but not the line or the ball. I screw around and plug cart 1 halfway in -- the paddles and line appear, but not the ball. I screw around s'more -- the paddles and ball appear, but not the line, and the ball doesn't detect the paddles, moving through them.

I cried for a long, long time.

Anyone have any idea what might be wrong, or who in the classic world is an Odyssey expert? (Yes, I should research this myself, but I'm being lazy.)

-- Z.

y-bot
03-30-2003, 11:05 PM
I was just working on one of these two night ago. Mine had no picture at all to begin with and I fixed that by adjusting things in the RF output box but now the ball barely appears on the screen in the corner. I have heard that these systems sometimes have a problem with loose solder joints. I don't know if that has to di with either of our problems. There are all kinds of adjustments that can be made inside you might try messing around with them and/or unplugging and plugging back in all the modules. I have the repair manual/schematics and I could send you a photocopy if you like. Also if you find someone who knows alot about repairing these please let me know too. Luckily I have a working one as well so I can compare them.

Thanks, y-bot