PDA

View Full Version : SNES help...



zektor
04-06-2003, 12:31 AM
I recently got ahold of a SNES for $13 (cheap I think) complete w/2 joysticks, power sup, and rf adaptor. When I first received it, I plugged it in and turned it on and the red light in front came on. See, I have NO games for the system (yet) so this is basically all I can do to test the system. Later, I just flipped the power switch without the power supply plugged in, and the power light came on for a second and then went out! I am assuming this was just discharge of electricity held in the unit. Well, I got done re-wiring my systems and plugging them all in, and now, when I turn the SNES on it doesn't light up power! I really don't know much about the SNES. I kind of passed it by while I was either drunk or in my Genesis world back then. I know the Jaguar needs a cart inside it to power up, is this (HOPEFULLY) the same situation on the SNES? Or did it just go bye bye?

Darth Vader
04-06-2003, 03:26 PM
Sounds like you had a power surge of some sort. Maybe the AC adaptor is shot. That might have been why they were selling it.

Danny

zektor
04-06-2003, 07:03 PM
Looks that way as well. Oh well...another one bites the dust!

Sylentwulf
04-06-2003, 11:23 PM
Try another AC adapter before you chuck it, the plug could have blown.

zektor
04-07-2003, 12:06 AM
Try another AC adapter before you chuck it, the plug could have blown.

Yeah, this could be. I don;t have any games for it anyway however. I'll probably just trade it, or sell it. I ALWAYS seem to have problems with Nintendo stuff. I think I'll just stay away from their consoles entirely.

dreamcaster
04-09-2003, 09:10 AM
Must just be your bad luck.

Never have any problems with any Nintendo stuff. Or video game stuff in general. The only things I have that screw up are:

N64 - Dodgy joystick (only my blue controller - other two are perfect still)
Atari 2600 - RF socket is loose (jiggling the cable usually fixes it)
SNES - The usual discolouration problem (no technical probs though)
NES - Worn 72-pin connector (only gives me a few problems though...)
Mega Drive - Loose AC adaptor socket (tightened it up a bit so it's not so bad)

I've had a pretty good run (especially since these are only minor temporary problems)