PDA

View Full Version : Sega CDX Problem



buttasuperb
10-19-2002, 12:25 AM
i just got a sega cdx today and im having some problems. using the audio cd player works fine running off the batteries, but when i plug the ac adaptor in, i cant play games or listen to audio cd's. when i press the power button, nothing shows up on the display. the ac adaptor that came with it, the plug going into the cdx is a little bent, but i dunno if the problem lies with that or if its on the cdx's side. i have a ac adaptor that came with my genny 3, but i dont know if its alright to use that one due to different voltage or whatever.

any help is appreciated.

Raedon
10-19-2002, 12:55 AM
first and formost, don't go just plugging ac adapters into it, rushing things without knowledge is the mother of all fuck-ups.

Is there a rating where the AC plugs into the CDX? And if so, is it the same as the adapter you got with the cdx?

Raedon
10-19-2002, 01:00 AM
A small backlit LCD display on the top of the unit displays the status of the player. The LCD is backlit only when the player is connected to an AC power source.

from the manual.

searching faqs..


The CDX can operate on two AA size batteries, but unfortunately, only audio CDs can be played while using batteries. Genesis carts and game CDs require the AC adapter.

buttasuperb
10-19-2002, 01:01 AM
yep. dc 9.5v on both the cdx and the adaptor.

Raedon
10-19-2002, 01:03 AM
hmm.. that's less then a Genesis adapter puts out.

but the AC adapter and the CDX have the same rating 9.5v and the AC adapter has the same or a higher Ma rating?

Power Usage: Genesis CDX AC (DC 9.5 V, 1.5 A)

buttasuperb
10-19-2002, 01:07 AM
Ma rating?

the cdx only says dc 9.5v right by the plug in.

the adaptor says for use with genesis cdx 9.5v 1.5a so its the right adaptor. the actual part that plugs in the cdx is a bit bent.

ok another question. say the previous owner used a different ac adaptor. would that fuck up the whole system, or only fuck up playing games, and the audio cd's still work?

im tryin to find out if this is fixable.

Raedon
10-19-2002, 01:16 AM
it could have, but if you get audio chances are what has happened here is someone has tripped on the AC cord and messed up the ac port so the only thing that works is the one thing that works off the batteries. the music CD part of the CDX.

First thing plug the adapter into a socket for a few minutes and see if it warms up. If it does then it probably works (i have yet to have an AC adapter for a post NES system die.) Then I would try putting the AC adapter in and holding it at different angels to see if you can get it to fire up. My guess is that you will get it to fire up but only at an extreme angle.. from here you will need to open it and solder some things.

buttasuperb
10-19-2002, 01:23 AM
i really hope thats the case. i looked at my genny 3 adaptor to see if was the same as the cdx one, and it was 10v instead of 9.5v. so i hope whoever had this before me didnt plug a different ac in and fuck everything up. but like you said, the audio works, so hopefully with some tweaking the games will work too.

thanks for the help raedon.

FABombjoy
10-19-2002, 11:55 AM
i really hope thats the case. i looked at my genny 3 adaptor to see if was the same as the cdx one, and it was 10v instead of 9.5v. so i hope whoever had this before me didnt plug a different ac in and fuck everything up. but like you said, the audio works, so hopefully with some tweaking the games will work too..

Voltage isn't really the key issue with AC adapters, it's the current rating. The Genesis 3 uses an AC adaptor rated at 300mA, 1/5 of the current supplied by the CDX power adapter. If you were to plug the Gen3 AC into a CDX, you'd almost certainly destroy something. However, as long as the current was adequate, you can get away with voltage in the 7.5-12V range; probably even higher.

I would first measure the output from the power supply. You want to eliminate the external possibilities just to be sure. If it works, it'll probably read somewhere around 12V. Since broken supplies can still read correct voltage, you want to test the power under load.

It probably (hopefully) just needs the power connector resoldered. The manufacturing process Sega used for their Gen 2 and later systems sucked as far as the power connector goes. The connectors are very prone to cold solder joints, partially due to the fact that the number of physical connections to the mainboard was reduced & the solder itself is the only load bearing element. I've had to fix the power on a handful of Gen2 and Nomad systems all due to cold solder. But, at least it's an easy fix. I haven't opened my CDX up to see if it's the same, tho.

raylydiard
07-12-2010, 06:20 AM
just go and find a AC socket power connector
slim ps2 uses the same type so should be easy to find a replacment and desolder the old ond and replace it and it should be fine
or if still no sound check the electrolytic capacitors
on the cd board if you can replace all of them it take hours i have done a few my self i have 6 sega cdx systems all was broken but now all working because of me take care guys i hope this helps


i just got a sega cdx today and im having some problems. using the audio cd player works fine running off the batteries, but when i plug the ac adaptor in, i cant play games or listen to audio cd's. when i press the power button, nothing shows up on the display. the ac adaptor that came with it, the plug going into the cdx is a little bent, but i dunno if the problem lies with that or if its on the cdx's side. i have a ac adaptor that came with my genny 3, but i dont know if its alright to use that one due to different voltage or whatever.

any help is appreciated.

mrbigreddog
07-12-2010, 12:06 PM
just go and find a AC socket power connector
slim ps2 uses the same type so should be easy to find a replacment and desolder the old ond and replace it and it should be fine
or if still no sound check the electrolytic capacitors
on the cd board if you can replace all of them it take hours i have done a few my self i have 6 sega cdx systems all was broken but now all working because of me take care guys i hope this helps

Why did you dig up this old thread.. The original post, and all other post besides your and mine. Are from 2002!!! 8 Years ago! Hopefully he's got the problem fixed by now!:duh:

PapaStu
07-12-2010, 03:38 PM
Wowza.... a 8 year thread necro.

**shimmied to Tech & Resto**