I recently purchased a used Sega Genesis (model 2) console at a retro gaming store around town, and I'm having a bit of trouble. The system itself came with a standard Sega 3-button controller. Whenever I boot up the console to play a game one of three things will happen: the controller will function correctly, it won't function at all, or, the most common is that all the buttons work except for D-pad up and right. At first I thought it was the controller, so I went back to the store the next day and bought a third-party pad called the "SuperPad" by Performance.

When I got home to try it out, none of the buttons worked correctly, and it seemed to be stuck in a D-pad left, down, and C button position (meaning that those buttons were being registered with the game as being always pushed down, ie: Sonic would always run to the left, look down and jump by himself). I tried typing in my problem on Google, and learned that the problem might be that the pins in the controller port are wearing out (??), and that I should check to make sure the traces on the PCB were not broken, and still soldered (seen here: http://koti.mbnet.fi/~ilesj/coll/pic/sms2-diagnosis.jpg)

I proceeded to open the Genesis, and when I flipped over the board I found nothing unusual, or so I think: I really don't know what I'm looking for that should be broken... everything still looks soldered to me. After cleaning the board with some rubbing alcohol, dusting off the internal controller contacts, and cleaning the plastic shell, I put it back together, and found some results: the third-party controller's D-pad and C button worked, but A and B did not. My official Genesis controller worked 100%, although sometimes the up and right directional buttons do not, so I have to power down the unit, disconnect the controller, and then try it again.

I would appreciate it if anybody could help me out, if they think they know what the problem might be. There's a chance that BOTH controllers might be broken, but it is strange considering the third-party one ALMOST started working 100% after cleaning the entire system. I'll be moving back to New York on Friday, so I might stop by Digital Press in the coming weeks; I don't know if you guys offer repairs or have any model two consoles in stock.