Results 1 to 8 of 8

Thread: Sega Saturn Model 2 Problem

  1. #1
    Insert Coin (Level 0)
    Join Date
    Jul 2008
    Location
    Bayamon, Puerto Rico
    Posts
    194
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Sega Saturn Model 2 Problem

    Hi,

    I have a sega saturn model 2, at first it wasnt reading discs, so I cleaned it using optical cloth and optical cleaner solution, and it worked, after a few weeks the saturn no longer read discs, instead as soon as I turn it on, the access led keeps blinking, I insert a music CD and it says drive empty, when I insert a game disk it says Checking Disk Format and then nothing, the main menu still does nothing and the access light blinks faster. any idea?

    thanks!

  2. #2
    Peach (Level 3) izarate's Avatar
    Join Date
    Dec 2007
    Location
    Mexico
    Posts
    603
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Dead laser? The Model 2 Saturn uses a JVC OPTIMA6

  3. #3
    Kirby (Level 13) megasdkirby's Avatar
    Join Date
    Oct 2003
    Location
    Bayamon, Puerto Rico
    Posts
    5,213
    Thanks Thanks Given 
    12
    Thanks Thanks Received 
    10
    Thanked in
    9 Posts
    Xbox LIVE
    megasdkirby
    PSN
    megasdkirby

    Default

    Well, I thougth about what you told me, and like I mentioned, it could be a defective lens or lens assembly. Try replacing the lens with a known good to see if that helps. Make sure it's the same make and model. If it works, then the problem is with the lens itself.

    If it is the lens, you can tweak the potentiometer to see what values give you success. I don't remember the original factory defaults, though.

    If you wish, and if you send me the model of the lens, I can see if I can find my spare so you can test it. That way, you know for certain if it's the lens or not.
    Proud owner of a Neo 25 Neo Geo Candy Cab!

  4. #4
    Alex (Level 15) InsaneDavid's Avatar
    Join Date
    Nov 2004
    Location
    Silicon Valley, USA
    Posts
    7,361
    Thanks Thanks Given 
    16
    Thanks Thanks Received 
    13
    Thanked in
    12 Posts

    Default

    To begin with, you have a Model 1 since there's an access light, not a Model 2 which removed the access light and has round buttons as opposed to oval - this is important to know when asking about repairs.

    There's a ribbon cable inside that runs from the motherboard up to the laser assembly, it has a couple folds in it. Unplug and clean the ends (both of them) and reseat the cable. I've had a few Model 1 systems that gave all kinds of screwy readings (drive empty, disc is incorrect region, games coming up as audio, spinning a couple times and stopping, not spinning at all) until reseating the cable. If anything it's an easy repair to try before moving on to more involved things. Start with the simple stuff like this before tweaking stuff, possibly damaging something that was working fine.

  5. #5
    Insert Coin (Level 0)
    Join Date
    Jul 2008
    Location
    Bayamon, Puerto Rico
    Posts
    194
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Thank you all for your help, Tomorrow I will clean both ends of the ribbon cable and test the unit, and I will reply with the results, thanks!

  6. #6
    Kirby (Level 13) megasdkirby's Avatar
    Join Date
    Oct 2003
    Location
    Bayamon, Puerto Rico
    Posts
    5,213
    Thanks Thanks Given 
    12
    Thanks Thanks Received 
    10
    Thanked in
    9 Posts
    Xbox LIVE
    megasdkirby
    PSN
    megasdkirby

    Default

    When you do, check the model of the lens while you are at it.
    Proud owner of a Neo 25 Neo Geo Candy Cab!

  7. #7
    Insert Coin (Level 0)
    Join Date
    Jul 2008
    Location
    Bayamon, Puerto Rico
    Posts
    194
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by megasdkirby View Post
    When you do, check the model of the lens while you are at it.
    how do i do that is there a number?

  8. #8
    Kirby (Level 13) megasdkirby's Avatar
    Join Date
    Oct 2003
    Location
    Bayamon, Puerto Rico
    Posts
    5,213
    Thanks Thanks Given 
    12
    Thanks Thanks Received 
    10
    Thanked in
    9 Posts
    Xbox LIVE
    megasdkirby
    PSN
    megasdkirby

    Default

    It should be labeled on the unit itself, or at least some type of text identifier.

    Take a pic of it if you can. That will surely help.
    Proud owner of a Neo 25 Neo Geo Candy Cab!

Similar Threads

  1. FS: Sega Saturn modchips (model 1 and model 2!)
    By APE992 in forum Buying and Selling
    Replies: 0
    Last Post: 11-04-2013, 02:54 PM
  2. Sega Genesis Model 2 problem
    By InsertCleverName in forum Technical and Restoration Society
    Replies: 5
    Last Post: 09-10-2012, 08:15 PM
  3. Need Input into Problem with Sega CD Model 1
    By Tempest228 in forum Technical and Restoration Society
    Replies: 17
    Last Post: 03-20-2012, 11:01 PM
  4. Model 1 Sega CD Problem.
    By Cloud121 in forum Technical and Restoration Society
    Replies: 3
    Last Post: 08-22-2007, 03:38 PM
  5. Model 1 Sega CD problem
    By gumbyandpals in forum Technical and Restoration Society
    Replies: 8
    Last Post: 06-01-2007, 09:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •