Results 1 to 6 of 6

Thread: Strange colecovision problem

  1. #1
    Banana (Level 7) Atarileaf's Avatar
    Join Date
    May 2004
    Posts
    1,483
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    1
    Thanked in
    1 Post

    Default Strange colecovision problem

    I have a CV and a bunch of games which I purchased recently. The problem is with time pilot specifically.

    When you first turn on a CV game, you get to that blue screen that allows you to press 1,2,3,etc to choose your skill level and the game starts.

    With every game, this works just fine. Not so with Time Pilot, when I get to this blue skill select screen, nothing happens when I press a keypad button. Its not the controllers because its fine with every other game. I cleaned the cart and it turns on, I get the title screen and it does go to the blue select screen, but with time pilot ONLY, I can't progress beyond that.

    Any suggestions/theorys?

  2. #2
    Kirby (Level 13) zektor's Avatar
    Join Date
    Jul 2002
    Location
    Classic Jersey
    Posts
    5,398
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    That is odd. Only advice I can give is to clean it again. Could be that the ROM is corrupt somehow.

  3. #3
    Great Puma (Level 12) Steve W's Avatar
    Join Date
    Jun 2006
    Location
    DFW Metroplex, Texas
    Posts
    4,417
    Thanks Thanks Given 
    44
    Thanks Thanks Received 
    32
    Thanked in
    29 Posts

    Default

    My Colecovision gets graphically glitchy after I turn it on, but once I push the reset button, it works fine.

    You might end up having to track down another Time Pilot. Hopefully it'll work better.

  4. #4
    Ghostbuster
    Greg2600's Avatar
    Join Date
    Aug 2006
    Location
    Soprano Land, NJ
    Posts
    3,859
    Thanks Thanks Given 
    5
    Thanks Thanks Received 
    48
    Thanked in
    43 Posts

    Default

    Quote Originally Posted by Steve W View Post
    My Colecovision gets graphically glitchy after I turn it on, but once I push the reset button, it works fine.
    Mine does that too, but only on a certain TV. That TV has a really lousy RF receiver, something I never knew could happen. Sharp.... Colecovisions are notorious for all kinds of gremlins, and the RF feed in general from them is not so great.
    The Paunch Stevenson Show free Internet podcast - www.paunchstevenson.com - DP FEEDBACK

  5. #5
    Kirby (Level 13) zektor's Avatar
    Join Date
    Jul 2002
    Location
    Classic Jersey
    Posts
    5,398
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by Greg2600 View Post
    Mine does that too, but only on a certain TV. That TV has a really lousy RF receiver, something I never knew could happen. Sharp.... Colecovisions are notorious for all kinds of gremlins, and the RF feed in general from them is not so great.
    Yeah, I have a JVC that I had to swap out with a Sanyo. The JVC is a better TV overall, but the RF is terrible. Sometimes it will register a signal, sometimes it doesn't, sometimes it buzzes loudly and all crazy. Thought it was the system at first, until I hooked other RF systems up to find the same issues. The cheap Sanyo (nice size tho...40") actually has a GREAT RF receiver. Unreal.

  6. #6
    Banana (Level 7) Atarileaf's Avatar
    Join Date
    May 2004
    Posts
    1,483
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    1
    Thanked in
    1 Post

    Default

    Yep, the timepilot seems to be dead. Doesn't matter how clean it is and which of my two CV's I play it in. Nor does it seem to matter which controller I have plugged in.

    Another thing I've noticed is my "Space Fury" acts strange. When it gets to the skill select screen, pressing any button on the keypad resets it to the title screen.

    What would cause that?

Similar Threads

  1. Strange NES problem!
    By Schiggidyd in forum Classic Gaming
    Replies: 4
    Last Post: 11-17-2012, 08:39 AM
  2. Somewhat strange 3DO problem (Panasonic FZ-10)
    By lakeflaccid in forum Technical and Restoration Society
    Replies: 2
    Last Post: 09-09-2007, 10:06 PM
  3. Strange Lynx problem
    By Damon Plus in forum Technical and Restoration Society
    Replies: 1
    Last Post: 01-22-2007, 09:24 AM
  4. FT/FS : Strange Colecovision 2-in-1 Red Multicart
    By Shernand in forum Buying and Selling
    Replies: 0
    Last Post: 07-30-2005, 06:32 PM
  5. Strange Encounter: Tempest for ColecoVision?
    By Aswald in forum Classic Gaming
    Replies: 1
    Last Post: 12-17-2004, 03:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •