Results 1 to 2 of 2

Thread: Purple Screen on Top Loading Famicom

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Insert Coin (Level 0)
    Join Date
    Jan 2007
    Posts
    25
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Purple Screen on Top Loading Famicom

    Hello,

    I recently acquired my first Famicom Disk System, and upon going to test it discovered that my top loading Famicom, which has been working for several years with really no issues at all, was delivering a consistent purple screen even with any regular Famicom cart I put in (Disk System out of the picture).

    Naturally the first thing I tried to do is clean everything involved: cartridge slot on the famicom itself as well as the connectors on multiple games, all of which I chose as test cases because in the past they had most consistently worked. I use the qtip/rubbing alcohol method on the carts, the plastic card/thin cloth/alcohol method to clean the cartridge slot. I've done both of these things multiple times, yet I never get anything past a purple screen.

    The next thought that entered my mind was replacing the 60 pin adapter that the Famicom uses. Since this is a Famicom and not an NES, tutorials are not as plentiful. Even so, I managed to find a place selling 60 pin slots for Famicoms, ordered one, and while I wait for it decided to open up my top loader to get the old one pulled out so it would be ready to go. I removed the two screws holding down the slot itself, but it doesn't seem to want to come up. I did a little bit of research on replacing the 72 pin adapter on the top loading NES, thinking maybe it wouldn't be too far off. Then, much to my horror, I read a post that said the top loaders actually have the slots soldered to the board. Can anyone confirm whether or not this is true?

    Here is an image for reference, in case it's needed:

    http://mognet.net/famicomslot.jpg

    Thanks!

  2. #2
    Strawberry (Level 2) bust3dstr8's Avatar
    Join Date
    Mar 2007
    Location
    Boston,MA USA
    Posts
    442
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Yup, 60P connector uses straight solder pins.
    Clowns Suck

    Clowns Suck

Similar Threads

  1. Sega Mega Drive 2 has purple flickering screen
    By Omega_X_ in forum Technical and Restoration Society
    Replies: 2
    Last Post: 11-14-2012, 06:21 AM
  2. Replies: 0
    Last Post: 08-19-2012, 07:24 PM
  3. 3D Dot Game Heroes loading screen homages (lots of pics)
    By Holger Czukay in forum Classic Gaming
    Replies: 12
    Last Post: 02-04-2011, 02:24 PM
  4. Sony Wega Has Purple Spot on Screen - Would Degaussing Fix It?
    By wingzrow in forum Technical and Restoration Society
    Replies: 4
    Last Post: 01-03-2010, 02:51 AM
  5. Mario Kart unique loading screen
    By PhantomInABox in forum Classic Gaming
    Replies: 2
    Last Post: 04-28-2008, 06:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •