Results 1 to 3 of 3

Thread: 6-Button controller not working in certain games

  1. #1
    Stuck in 1998 Cloud121's Avatar
    Join Date
    May 2007
    Location
    South Town
    Posts
    533
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    1
    Thanked in
    1 Post
    Xbox LIVE
    Cloud121D
    PSN
    Cloud121
    Steam
    Cloud121D

    Default 6-Button controller not working in certain games

    For some reason, my six-button controller for my MegaDrive doesn't like certain games (or the games don't like them). I know of the usual suspects (Forgotten Worlds is the most famous one. Surprisingly, my copy plays fine even without holding the Mode button down), and have no issues with those (Golden Axe II, Ms. Pac-Man, etc.). But it's three games in particular that don't play nice with my 6-button.

    Alien 3
    Mortal Kombat
    William's Arcade Greatest Hits

    Alien 3 simply doesn't not want to respond, even if I hold the Mode button down. Mortal Kombat has serious response issues (I have to press REALLY hard on the buttons), but works fine if I hold Mode to put it into 3-button mode. William's Arcade is similar to Mortal Kombat's situation.

    I've tried all three of my official Sega 6-button controllers (MK-1653, MK-1470 Majesco, and MK-1470 TecToy), disconnected the official extension cord and tried with all three as well. Even went so far as to unplug the 32X, then tried the previous six combinations, and these three games are still giving me issues. I do no understand at all. Hell, I had no issues with Mortal Kombat until very recently. Alien 3 has been a problem for several months now. I remember playing Alien 3 YEARS ago with my 6-button and it working fine.

    I have absolutely no isses with a standard 3-button controller. It's just the 6-button.

    My MegaDrive is a USA Model 2 VA3 board, 3/4 plate.


    I haven't tested it on my USA VA5 Model 1 as it is packed away (and I don't have a SCART cable for it at the moment).
    My Game Collection
    "I am only what you see me as." - Obsidian Rose

  2. #2
    Insert Coin (Level 0)
    Join Date
    Jan 2016
    Posts
    21
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    I'm not an expert on this and I'm not familiar with the MegaDrive but since no one else has given any input I'll give it a go. Since you say you've tried three different controllers (all official) and you also said that the games all worked a few years ago, I can only assume that the problem is with your console itself somehow not being able to properly receive the signals from these games. I read somewhere on this site several months ago about how each game has it's own coding or something that corresponds to how it receives button controls. I'll try and find it so that it will make more sense. But I can almost guarantee you that it's not an issue of the game or the controllers. The best way to verify this obviously is to try each one in another MegaDrive. If you can't get a hold of another MegaDrive to try it on then the next best thing is to try cleaning the inside of the console and see if it functions any better, although I can pretty much guarantee you that it won't solve anything if the problem persists with only these 3 games.

  3. #3
    Insert Coin (Level 0)
    Join Date
    Jan 2016
    Posts
    21
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    In a similar thread called "SNES Controller won't work for some games" a person suggested "that the games that don't work handle or call the commands from the controller in a different way from the ones that work and the path it takes from the controller through the system to get results is messed up in the system some where. Like a bad memory controller that can't address correctly at higher values or ram it self that doesn't get used in the games that work but gets used in the games that don't and that's where the control call is. Not saying that's it specifically but as an example." If all that makes sense to you.

    Another person in that same thread suggested that maybe it was a cold solder joint. I would say open up your MegaDrive and check the solder connections on the board. Do a visual inspection first and if nothing looks odd then push on them a little and see how they feel (obviously not with it plugged in and running).

    Beyond that I really have no other ideas. Hope you figure it out.

Similar Threads

  1. SMS gamepad - button stopped working
    By Greg2600 in forum Technical and Restoration Society
    Replies: 2
    Last Post: 05-27-2011, 07:51 AM
  2. Atari Lynx - A button not working
    By titanzguard in forum Technical and Restoration Society
    Replies: 5
    Last Post: 06-13-2008, 11:34 PM
  3. Replies: 1
    Last Post: 12-17-2007, 12:30 AM
  4. WTB: 3do 6-button controller and games
    By McSega in forum Buying and Selling
    Replies: 0
    Last Post: 09-08-2004, 04:50 PM
  5. Genesis button not working.
    By GameNinja in forum Technical and Restoration Society
    Replies: 7
    Last Post: 08-16-2004, 12:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •