Results 1 to 3 of 3

Thread: NES-101 Toploader Grey Screen Issue - Voltage reading from ground?

  1. #1
    Insert Coin (Level 0)
    Join Date
    Mar 2016
    Posts
    6
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default NES-101 Toploader Grey Screen Issue - Voltage reading from ground?

    I recently picked up a "not working" Toploader to try and repair. On testing, all I get is a grey screen. I get the same grey screen if there's no cart installed. The cart is fine, the cart slot is fine. Cleaning won't have any effect, but it's as if the system doesn't even acknowledge a cart installed. What is the screen on a working toploader normally like if you try and boot it up without a game?

    When I opened it, there was some significant orange stuff on the bottom of the casing, indicating something spilled. There are some spots on the board, but it's mostly clean.

    I've re-capped the whole system, but still getting the grey screen. I've tried some troubleshooting, and found some peculiar issues.

    1. Reset switch wasn't working. I could not get continuity across the switch when engaged. I've desoldered and cleaned it, but haven't put it back on yet.

    2. Voltage Regulator and fuse are good. I get 12v in, and 5v out.

    3. I get 5v from the ground. This I found odd. I'm not sure where this would come from, whether the chips are defective and sending voltage where it shouldn't, or there's somehow a short somewhere. I do NOT get continuity between all 5v sources and ground. I'm in the process of searching for a short. Even more peculiar, is while powered with the AC unplugged, I still read 5v off the ground ONLY if the RF plug is installed. If unplugged, I lose 5v. I've never tested this with other systems, however I know the RF works, as I use it on my NES frontloader.

    Any suggestions on what I can check? Any common culprits?

  2. #2
    Insert Coin (Level 0)
    Join Date
    Nov 2018
    Location
    Lebanon, PA, USA
    Posts
    87
    Thanks Thanks Given 
    59
    Thanks Thanks Received 
    7
    Thanked in
    7 Posts
    Steam
    Maruko Tenada

    Default

    Hey, sorry your having trouble. Not sure I can help, but I'm curious to know if you got anywhere with this.

  3. #3
    Insert Coin (Level 0)
    Join Date
    Jan 2019
    Posts
    4
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Is this voltage seen on the main ground or only on one of the ground circuits? If it is the latter then you may have an open connection on the ground side.

Similar Threads

  1. Magnvox Odyssey 2 White and Grey Screen Problem
    By thegamezmaster in forum Technical and Restoration Society
    Replies: 23
    Last Post: 07-27-2014, 10:12 PM
  2. green, grey, or blue screen on your nes?
    By Niku-Sama in forum Classic Gaming
    Replies: 17
    Last Post: 05-22-2014, 05:09 PM
  3. PS2 issue - not reading blue games
    By Dire 51 in forum Technical and Restoration Society
    Replies: 8
    Last Post: 03-20-2007, 05:49 PM
  4. Video issue on toploader?
    By GodsLabRat in forum Classic Gaming
    Replies: 5
    Last Post: 04-11-2005, 11:54 PM
  5. NES help! Grey screen???
    By simonbelmont7 in forum Classic Gaming
    Replies: 8
    Last Post: 04-16-2003, 06:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •