Results 1 to 5 of 5

Thread: 3G OLED Vita discharges battery completely when turned off

  1. #1
    Great Puma (Level 12) YoshiM's Avatar
    Join Date
    Jul 2002
    Location
    WI
    Posts
    4,137
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    15
    Thanked in
    15 Posts
    Xbox LIVE
    YoshiDM
    PSN
    YoshiDM
    3DS Friend
    0860-4642-4923

    Default 3G OLED Vita discharges battery completely when turned off

    I recently bought a PS Vita OLED model that just happened to have 3G/cellular network capability. The person I bought it from said the battery doesn't hold a charge over a day when turned off. I replaced the battery in hopes that would be the issue. Like before, the Vita had no charge after a day of being turned off. I removed the SIM card and turned off the GPS to no avail. Doing a Google search showed others had this problem as well but no real solution beyond what I did.

    Anyone have any thoughts on this?

    Thanks!

  2. #2
    Great Puma (Level 12) YoshiM's Avatar
    Join Date
    Jul 2002
    Location
    WI
    Posts
    4,137
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    15
    Thanked in
    15 Posts
    Xbox LIVE
    YoshiDM
    PSN
    YoshiDM
    3DS Friend
    0860-4642-4923

    Default

    I've come to the conclusion that the drain might be coming from the 3G modem. I read some posts that mention it and a couple folk had either replaced the modem or just yanked it out. I want to do this but I stripped the heads on the two screws that hold the modem down.

    If I'm able to get a bit and safely do this and it works, I'll let you know.

  3. #3
    ServBot (Level 11) Niku-Sama's Avatar
    Join Date
    Aug 2005
    Location
    Deadford, OR
    Posts
    3,651
    Thanks Thanks Given 
    2
    Thanks Thanks Received 
    21
    Thanked in
    19 Posts

    Default

    I Fix it kits keep that from happening, might help get them out too

  4. #4
    Great Puma (Level 12) YoshiM's Avatar
    Join Date
    Jul 2002
    Location
    WI
    Posts
    4,137
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    15
    Thanked in
    15 Posts
    Xbox LIVE
    YoshiDM
    PSN
    YoshiDM
    3DS Friend
    0860-4642-4923

    Default

    Quote Originally Posted by Niku-Sama View Post
    I Fix it kits keep that from happening, might help get them out too
    I checked out the kits and saw the site had a few tips to remove screws with stripped heads. Thanks!

  5. #5
    Great Puma (Level 12) YoshiM's Avatar
    Join Date
    Jul 2002
    Location
    WI
    Posts
    4,137
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    15
    Thanked in
    15 Posts
    Xbox LIVE
    YoshiDM
    PSN
    YoshiDM
    3DS Friend
    0860-4642-4923

    Default

    Well, I tried some of the methods that I Fix It site gave but no result. I took the plunge and carefully used my smallest bit, which was about the same size as the shaft the screws are in. After some pressure, the top of the screw came right off! After prying the new screw-top metal cap off the end of my bit, I worked on the other screw and got the same result. The modem came right out. I blew out any metal shavings, reassembled and charged the Vita. After a full charge I unplugged the Vita and let it sit overnight.

    This morning I crossed my fingers and powered up the Vita. It started and had a full charge! Only issue is a cellular error that pops up at start.

Similar Threads

  1. Replies: 0
    Last Post: 05-02-2015, 06:54 PM
  2. The NES Zapper Light Gun on a OLED screen?
    By Kokonoe in forum Classic Gaming
    Replies: 4
    Last Post: 06-29-2014, 08:44 PM
  3. Replies: 4
    Last Post: 12-02-2012, 07:11 PM
  4. Replies: 0
    Last Post: 07-08-2012, 09:05 PM
  5. Replies: 3
    Last Post: 02-22-2012, 01:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •