Results 1 to 2 of 2

Thread: Turbografx 16...video signal help

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Crono (Level 14) Kroogah's Avatar
    Join Date
    Jul 2002
    Location
    Captain Falcon is displeased by this
    Posts
    6,142
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts
    Xbox LIVE
    Holger Czukay

    Default Turbografx 16...video signal help

    I have a TG16 that works fine when I don't have my controller plugged in...when the controller (a Turbo Stick) is plugged in the picture gets really wavy and full of static to the point that it is unplayable. If I pull up or push down on the controller's plug the picture almost goes back to normal...is this a common problem? How can I fix it? Buy a different controller?


  2. #2
    Pac-Man (Level 10) omnedon's Avatar
    Join Date
    Sep 2002
    Location
    Canada
    Posts
    2,908
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    I'm wondering if your internal RF shield is interfering some way, perhaps shorting with the controller.

    Someting is touching when it's not supposed to.

    You could go inside and remove the RF shield, but it could make RF output crap all the time.

    If you bought a TurboBooster, and used comosite out only the problems would likely vanish as well.
    ... for your gaming and iPod service needs http://www.oldschoolgamer.com/ For all your Video Game console and iPod upgrade/repair needs!

Similar Threads

  1. TurboGrafx-16 Video Fuzzy and Inconsistent
    By gir489 in forum Technical and Restoration Society
    Replies: 4
    Last Post: 02-05-2010, 09:49 PM
  2. For Auction Model 1 Genesis with s-video, Turbografx 16 system and more!
    By PC-ENGINE HELL in forum Buying and Selling
    Replies: 1
    Last Post: 10-14-2009, 08:26 AM
  3. Help with Genesis 2 S-Video mod (CXA1145M encoder) - No signal. - FIXED!!!
    By izarate in forum Technical and Restoration Society
    Replies: 20
    Last Post: 10-24-2008, 01:34 PM
  4. Getting any video signal out of the GBA??
    By Bratwurst in forum Technical and Restoration Society
    Replies: 3
    Last Post: 06-28-2005, 11:03 AM
  5. Video/Game signal splitter.
    By jajaja in forum Technical and Restoration Society
    Replies: 8
    Last Post: 04-09-2005, 07:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •