Results 1 to 5 of 5

Thread: Famicom disk system question.

  1. #1
    Crono (Level 14)
    Join Date
    Dec 2004
    Posts
    6,221
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Famicom disk system question.

    I recently recived a Sharp Twin Famicom system.
    But when I try to play disks i get error 2. battery err.

    I did some search on this and found out that the batteries where dead, but what are these batteries? I thought all went on the AC adapter.

    Any suggestions on how to fix this?

  2. #2
    Pac-Man (Level 10)
    Join Date
    Jul 2002
    Posts
    2,802
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    1
    Thanked in
    1 Post

    Default

    I've never had a Twin, but here's a guess: are there two AC outs? I.E., can you plug it in twice? The original Disk System used size D batteries and had an optional AC power plug (sold seperately!), I don't think you can use batteries in the Twin Fami, though. I'm guessing it's just a generic "no power to disk drive" error, it's probably not plugged in.

  3. #3
    Bell (Level 8) y-bot's Avatar
    Join Date
    Jul 2002
    Location
    NE Portland, Oregon
    Posts
    1,713
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    One AC adapter powers the whole thing. There could be a power supply problem inside I suppose. What are you using for an AC adapter? I have a universal one that I've used at 7.5V & 9V on mine. I was actually just working on mine a couple of days ago. I had it working a year or so ago but it isn't working now. I tried two different drives that both have new belts but I get error 1 & 21 or 22 depending on the speed of the motor.
    y-bot

  4. #4
    Crono (Level 14)
    Join Date
    Dec 2004
    Posts
    6,221
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    I use a universal power adapter set to 7.5v as stated back on the famicom.
    The cartridges works perfectly. I havnt tried the original power adapter which included because i dont have a 220v to 110v converter.

    There are 4 outputs in the back. One for power, 1 white and 1 yellow (for video and sound) and another im not quite sure what is. It looks like the old keyboard cords if you know how they look like. I dont see anywhere where you can insert any batteries either.

    But shall I return it? I mean, is there no way to fix this? What is the problem?

  5. #5
    Crono (Level 14)
    Join Date
    Dec 2004
    Posts
    6,221
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    I have taken a picture now (alittle blurry) of the back of the famicom.



    On the input to the left it says RF(japanese signs here).
    What is this?

Similar Threads

  1. Famicom disk system question
    By bigred5687 in forum Classic Gaming
    Replies: 13
    Last Post: 01-31-2011, 02:55 PM
  2. Famicom Disk System power supply question.
    By DarthKur in forum Technical and Restoration Society
    Replies: 12
    Last Post: 10-09-2007, 05:41 AM
  3. Famicom Disk System question
    By nesfanatic in forum Technical and Restoration Society
    Replies: 6
    Last Post: 09-03-2004, 10:16 PM
  4. Famicom disk system power question
    By nesfanatic in forum Classic Gaming
    Replies: 1
    Last Post: 05-30-2004, 05:07 PM
  5. Famicom Disk System error messages (Question)
    By spoon in forum Classic Gaming
    Replies: 3
    Last Post: 09-27-2003, 04:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •