Results 1 to 9 of 9

Thread: pc engine duo board

  1. #1
    Cherry (Level 1)
    Join Date
    Apr 2005
    Location
    Brazil
    Posts
    323
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts
    Xbox LIVE
    arthurotaku

    Default pc engine duo board

    Anyone have images of pce duo board with explain of parts? Sound is gone in my pce, it's a internal problem

    XBL: ArthurOtaku
    PSN: Arthur-Otaku

  2. #2
    Cherry (Level 1)
    Join Date
    Jan 2004
    Location
    Bay Area, California
    Posts
    321
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Re: pc engine duo board

    Quote Originally Posted by Arthur-Otaku
    Anyone have images of pce duo board with explain of parts? Sound is gone in my pce, it's a internal problem
    I've been looking and asking for this for years. It appears no one knows anymore.

    I have figured out many other functions on the board but none of them are redbook audio
    Check out my site for Turbo Grafx/Duo, PCE, SuperGuns, and Sega Genesis mods and more.....
    http://www.multimods.com

  3. #3
    Cherry (Level 1)
    Join Date
    Apr 2005
    Location
    Brazil
    Posts
    323
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts
    Xbox LIVE
    arthurotaku

    Default Re: pc engine duo board

    Quote Originally Posted by D-Lite
    Quote Originally Posted by Arthur-Otaku
    Anyone have images of pce duo board with explain of parts? Sound is gone in my pce, it's a internal problem
    I've been looking and asking for this for years. It appears no one knows anymore.

    I have figured out many other functions on the board but none of them are redbook audio
    I found some posts of pc duo sound problem in neo-geo.com forums with photos of board, maybe it can help

    XBL: ArthurOtaku
    PSN: Arthur-Otaku

  4. #4
    Cherry (Level 1)
    Join Date
    Jan 2004
    Location
    Bay Area, California
    Posts
    321
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Re: pc engine duo board

    Quote Originally Posted by Arthur-Otaku
    Quote Originally Posted by D-Lite
    Quote Originally Posted by Arthur-Otaku
    Anyone have images of pce duo board with explain of parts? Sound is gone in my pce, it's a internal problem
    I've been looking and asking for this for years. It appears no one knows anymore.

    I have figured out many other functions on the board but none of them are redbook audio
    I found some posts of pc duo sound problem in neo-geo.com forums with photos of board, maybe it can help
    Haha, yeah, check the name of the user that posted those.
    Check out my site for Turbo Grafx/Duo, PCE, SuperGuns, and Sega Genesis mods and more.....
    http://www.multimods.com

  5. #5
    Insert Coin (Level 0)
    Join Date
    Dec 2004
    Location
    NJ,USA
    Posts
    95
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    I just put a new laser in my duo and it fixed some sound problems as well as some other problems. I've been using it alot now that it works like new but the 2 big transistors are gettin really hot so now I'm worried about them causing damage to the system.
    D-Lite, can I put them on a little board outside my Duo to prevent them from hurting the system?

  6. #6
    Cherry (Level 1)
    Join Date
    Jan 2004
    Location
    Bay Area, California
    Posts
    321
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by gcl1984
    I just put a new laser in my duo and it fixed some sound problems as well as some other problems. I've been using it alot now that it works like new but the 2 big transistors are gettin really hot so now I'm worried about them causing damage to the system.
    D-Lite, can I put them on a little board outside my Duo to prevent them from hurting the system?
    You could. Which two "transistors"? Are you sure you're not talking about the capacitors?
    Check out my site for Turbo Grafx/Duo, PCE, SuperGuns, and Sega Genesis mods and more.....
    http://www.multimods.com

  7. #7
    Strawberry (Level 2) phreak97's Avatar
    Join Date
    Jun 2005
    Location
    Adelaide, South Australia
    Posts
    592
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts
    Xbox LIVE
    phreak97

    Default

    heat is not an issue, i mean, it is, but not in the way you mean. it doesnt matter about the heat being on the board, it's unlikely theres any heat sensative components next to them. if they were going to cause damage, they'd do it electronically, not in the form of heat. if youre really worried about them, and they are transistors, see if they have tabs with holes through them attached, if they do, you can attach small heat sinks to them with screws.

    after working on a turbo express, i may be jumping to conclusions, but if youre getting no sound at all, it's more than likely a capacitor. when i got my turbo express, EVERY capacitor was dead, or on it's way out. the sound one was one of the few which had a little life left, suprisingly. but no sound is a common TE fault, so it's probably a common turbo fault all round, and can be fixed by replacing capacitors untill things work again.

  8. #8
    Insert Coin (Level 0)
    Join Date
    Dec 2004
    Location
    NJ,USA
    Posts
    95
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    the 2 big ones.I'm not home but from memory I'm gonna guess they are lm740.They are the 2 surrounded by all the caps.
    They already have heat sinks on them and they run so hot you can feel the system case gettin warm on the left on the top .
    I think there are theories that the heat from them ruins the caps surrounding them which in turn gives sound problems.

  9. #9
    Cherry (Level 1)
    Join Date
    Jan 2004
    Location
    Bay Area, California
    Posts
    321
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    The heat can cause problems with capacitors drying out and failing. Not to mention that around the era of the first Duo's, there were supposedly many issues with electolytic capacitors having short lifespans.

    But I think the sound problem is probably due to a dead amp. I'm working on that....
    Check out my site for Turbo Grafx/Duo, PCE, SuperGuns, and Sega Genesis mods and more.....
    http://www.multimods.com

Similar Threads

  1. Replies: 0
    Last Post: 03-29-2013, 06:42 AM
  2. Pc engine only works when I touch the board?
    By paul773car in forum Technical and Restoration Society
    Replies: 4
    Last Post: 04-09-2012, 07:06 AM
  3. Replies: 1
    Last Post: 01-22-2012, 05:36 PM
  4. Replies: 2
    Last Post: 05-29-2008, 05:12 PM
  5. Replies: 0
    Last Post: 05-30-2007, 03:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •