Results 1 to 5 of 5

Thread: TurboGrafx-16 Video Fuzzy and Inconsistent

  1. #1
    Insert Coin (Level 0)
    Join Date
    Feb 2010
    Posts
    3
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default TurboGrafx-16 Video Fuzzy and Inconsistent

    We dusted off an old TG16 and tried to play it, but it hasn't been played in years.

    When we got it all hooked up, we get fuzzy and inconsistent video.

    My friend thinks it's the cable, but I think it's the video jack. I read online and according to repair guide, it's usually the capacitors on the PCB that is causing the video to be faulty.

    The audio works. We tested Air "Zonk" and we can hear it fine.

    What can I do to figure out the problem?

  2. #2
    Alex (Level 15) Custom rank graphic
    Gameguy's Avatar
    Join Date
    Dec 2008
    Location
    Richmond Hill, Ontario (Canada)
    Posts
    7,712
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    51
    Thanked in
    45 Posts

    Default

    Check the easiest things first, I think the cable/RF switch would be the easiest to test first. Do you have an NES, SNES, SMS, or Model 1 Genesis? They all use the same type of RF switch, if you have another one try it out and see what happens.

  3. #3
    Insert Coin (Level 0)
    Join Date
    Feb 2010
    Posts
    3
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    No. I used to have all of those, but I sold them.

    I have a continuity tester. Is where a way I can use it to test the cable?

  4. #4
    Pretzel (Level 4) Orion Pimpdaddy's Avatar
    Join Date
    Aug 2008
    Location
    night sky
    Posts
    822
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    2
    Thanked in
    2 Posts

    Default

    Are you using composite video or RF?

  5. #5
    Insert Coin (Level 0)
    Join Date
    Feb 2010
    Posts
    3
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    It's the old RF plug that came with the system.

Similar Threads

  1. Fuzzy corners on an old CRT TV
    By treismac in forum Technical and Restoration Society
    Replies: 14
    Last Post: 03-01-2012, 12:04 AM
  2. Fuzzy Picture On Colecovision
    By mobiusclimber in forum Technical and Restoration Society
    Replies: 2
    Last Post: 01-06-2010, 10:21 PM
  3. Genesis Fuzzy Sound
    By gumbyandpals in forum Technical and Restoration Society
    Replies: 9
    Last Post: 03-05-2008, 07:36 PM
  4. Turbografx 16...video signal help
    By Kroogah in forum Technical and Restoration Society
    Replies: 1
    Last Post: 04-23-2004, 04:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •