Results 1 to 5 of 5

Thread: Pc engine only works when I touch the board?

  1. #1
    Insert Coin (Level 0) paul773car's Avatar
    Join Date
    Apr 2010
    Posts
    6
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Pc engine only works when I touch the board?

    I have pc engine duo which doesnt work, Just had it apart today and oddly it works perfectly whenever I touch any part of the board. Anyone any ideas? It appears to pick up interference or something but as soon as I touch a part of the board it woeks perfectly?

  2. #2
    Pretzel (Level 4)
    Join Date
    Sep 2005
    Posts
    819
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by paul773car View Post
    I have pc engine duo which doesnt work, Just had it apart today and oddly it works perfectly whenever I touch any part of the board. Anyone any ideas? It appears to pick up interference or something but as soon as I touch a part of the board it woeks perfectly?
    bad grounding could do that, so can a disconnected IC pin, the latter is easier to eliminate so start there. Also is it completely dead or does either the card or cd part work when you are not touching the board?

  3. #3
    Insert Coin (Level 0) paul773car's Avatar
    Join Date
    Apr 2010
    Posts
    6
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Both work when I'm touching it, and its definately not the pressure on the board as even the lightest of touches and it works. I have cleaned up the grounds and resoldered nearly everything I have also replaced all the caps.

    Thanks for helping, I'll check the IC's but to be honest they look ok

    Paul

  4. #4
    Pretzel (Level 4)
    Join Date
    Sep 2005
    Posts
    819
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by paul773car View Post
    Both work when I'm touching it, and its definately not the pressure on the board as even the lightest of touches and it works. I have cleaned up the grounds and resoldered nearly everything I have also replaced all the caps.

    Thanks for helping, I'll check the IC's but to be honest they look ok

    Paul
    I had a dead Sega CD once, it displayed the bios and then died when powered on. It turned out to be 3 pins were lifted on one of the ICs, It took about 15x magnification to see the broken connections. Don't write it off until checking all the pins, check the corner pins first as they are more prone to this.

  5. #5
    Insert Coin (Level 0) paul773car's Avatar
    Join Date
    Apr 2010
    Posts
    6
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Ok, went to bed at 2:30am but I think I have solved it. Well it's working. Checked the IC's again but they looked ok. In the end there's a small connector that goes from the board to the cd unit when I touched it I got lots of inteference and the unit stopped working I wrapped it in foil then insulating tape and its now working perfectly. Odd but I'm happy!

    Thanks for the help

    Paul

Similar Threads

  1. Replies: 0
    Last Post: 03-29-2013, 06:42 AM
  2. Replies: 2
    Last Post: 12-09-2009, 05:18 PM
  3. Replies: 2
    Last Post: 05-29-2008, 05:12 PM
  4. pc engine duo board
    By Arthur-Otaku in forum Technical and Restoration Society
    Replies: 8
    Last Post: 11-30-2005, 08:49 PM
  5. PC engine covertors--play PC Engine games on a TG16--$34
    By Querjek in forum Buying and Selling
    Replies: 0
    Last Post: 05-25-2004, 08:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •