Results 1 to 11 of 11

Thread: SNES Graphics Issues

  1. #1
    Insert Coin (Level 0)
    Join Date
    May 2012
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Question SNES Graphics Issues

    Okay, So. I recently picked up an old Super Nintendo System from a vintage store for like 75 bucks. It came with a pretty nice selection of 20 games(many with original boxes as well as instruction manuals), the cords to hook it up, two controllers and hell, it even had the old Nintendo Power ad in the Original Snes Box.

    Needless to say, I was utterly stoked. I hadn't had one of these since I was a kid and opening the box pulling it out was like Christmas in April.

    But then, Today I hooked it up when I finally had time to play it and popped in Super Mario World. Everything seemed beautiful at first. But then once I got to the overworld I knew something was up when there was no Mario Sprite. It was weird, but I pressed on. I entered a level and my sprite appeared and when I beat the level I went back to the overworld and could see Mario and Yoshi. Then, I entered the next level and my sprite was gone. Infact, I couldn't see any sprites at all. I couldn't even see coins or mushrooms, It was the most peculiar thing ever.

    So I dealed with it and just died on purpose and reloaded the level until it worked. Everything was okay working like this until I got to the first world's castle, my sprite(or any of the enemies) wouldn't appear no matter how many times I loaded the level. It was pretty irritating. I said "Oh well, I'll get a new Super Mario World."
    So then I popped in my favorite SNES game of all time, The Legend of Zelda: A Link to the Past. I could tell something was... off starting it up and going to the title screen but I chalked it up to being my HDTV being too advanced for the snes, but then I go to start a character and I notice that the other person's character who played before had these odd horizontal lines going through it, it was the weirdest thing I'd ever seen. And It really sucked because I remember this game being pretty good graphics even when I played it on a rom again a few years ago. Even the final boss has those odd lines going through him. I started a new character, same thing.

    I googled around and to not much avail for this specific issue, but then I stumbled upon this website of awesome like minded people such as myself(I'm really into collecting older consoles/games and restoring them to add to my collection to save and protect for many years to come)who seemed to know what they were talking about.

    So does anything have any idea what this issue could be? I assume that since two different carts had graphic / sprite issues that the problem is the console. But tell me what you guys think.
    I took pics to post so you guys could get a visual.

    Click image for larger version. 

Name:	IMG_0151.jpg 
Views:	40 
Size:	94.8 KB 
ID:	5071Click image for larger version. 

Name:	IMG_0152.jpg 
Views:	44 
Size:	95.8 KB 
ID:	5072Click image for larger version. 

Name:	IMG_0153.jpg 
Views:	52 
Size:	87.6 KB 
ID:	5073Click image for larger version. 

Name:	IMG_0155.jpg 
Views:	71 
Size:	90.7 KB 
ID:	5074Click image for larger version. 

Name:	IMG_0156.jpg 
Views:	50 
Size:	80.5 KB 
ID:	5075

  2. #2
    Pretzel (Level 4) Orion Pimpdaddy's Avatar
    Join Date
    Aug 2008
    Location
    night sky
    Posts
    822
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    2
    Thanked in
    2 Posts

    Default

    What kind of connection are you using? RF, composite, or s-video?

  3. #3
    Insert Coin (Level 0)
    Join Date
    May 2012
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Well I had been using composite, but I switched to the RF switch that came with it and hooked it up with that.

    Same issue.

  4. #4
    Pretzel (Level 4) APE992's Avatar
    Join Date
    Jun 2007
    Location
    Chico, CA
    Posts
    999
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts
    Xbox LIVE
    APE992

    Default

    PPU looks shot. In some of those pictures it looks like an entire layer is missing.
    I fix things. You name it, I'll work on it. Want something modded? Recapped?

  5. #5
    Key (Level 9) wiggyx's Avatar
    Join Date
    Feb 2012
    Posts
    1,844
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Have you tried another TV yet? Doesn't seem likely to be the culprit, but it's a pretty easy thing to rule out.

  6. #6
    Insert Coin (Level 0)
    Join Date
    May 2012
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    What is the PPU, can it be repaired/replaced?

    And yeah, I tried it on another LCD tv. Unfortunately I don't have access to any older tv sets at the time, but I doubt that the tv is the issue.
    It did seem like a layer was missing, particularly in Mario. But it's weird that it only happens sometimes, and in Zelda the only apparent issue is the missing lines through the sprites.

  7. #7
    Strawberry (Level 2) bust3dstr8's Avatar
    Join Date
    Mar 2007
    Location
    Boston,MA USA
    Posts
    442
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    The PPUs are the grfx processors. Your machine can't access the data in a certain address range and that data won't be displayed. Each game will have something different stored there
    so the result will be different with each cart..

    This could be something as simple as bad trace to a ram chip enable or as Ape said...half the
    adress bus on the PPU could be shorted out.


    SNES are cheap and even the cheapest repair will probally run the cost of a replacement console.


    http://console5.com/techwiki/images/...Controller.png
    Clowns Suck

    Clowns Suck

  8. #8
    Insert Coin (Level 0)
    Join Date
    May 2012
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Well okay. I was probably going to pick up a Snes-101 anyway(That's the one I had as a kid, nostalgia), but before I do I might as well try to fix this if I can.

    What you'ure saying about repair price bust3dstr8, that's considering the parts involved or perhaps taking it somewhere(if such a place exists anymore) to get it fixed?

  9. #9
    Strawberry (Level 2) bust3dstr8's Avatar
    Join Date
    Mar 2007
    Location
    Boston,MA USA
    Posts
    442
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    The only brick am mortar electronic repair shops I know of charge $55-$75 hour
    with a 1 hour minimum charge.


    Forum member repairs can probally be found cheaper, but then add in two way shipping.


    Seems like a lose lose. I would just keep that console for parts and try to fix it
    yourself when you have time.
    Clowns Suck

    Clowns Suck

  10. #10
    Pretzel (Level 4) APE992's Avatar
    Join Date
    Jun 2007
    Location
    Chico, CA
    Posts
    999
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts
    Xbox LIVE
    APE992

    Default

    I'd buy it for parts but it isn't worth too much as it is.
    I fix things. You name it, I'll work on it. Want something modded? Recapped?

  11. #11
    Insert Coin (Level 0)
    Join Date
    May 2012
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Yeah.... I'll probably just hold onto it. If nothing else, the shell is nice and it's a pretty good looking Snes compared to most others I've seen.

    I mean, it DOES play games... Sort of. It's just such a weird issue.

    Thanks for all your help guys!

Similar Threads

  1. Replies: 0
    Last Post: 11-29-2014, 05:17 PM
  2. SNES Garbled Graphics
    By alec006 in forum Technical and Restoration Society
    Replies: 3
    Last Post: 08-05-2014, 11:21 PM
  3. SNES with graphics issue in certain games
    By Guust in forum Technical and Restoration Society
    Replies: 2
    Last Post: 05-16-2014, 06:30 AM
  4. SNES Graphics Downloader v1.0
    By astaroth in forum Classic Gaming
    Replies: 7
    Last Post: 05-17-2011, 10:44 AM
  5. Problems with SNES Graphics
    By 98redM6 in forum Technical and Restoration Society
    Replies: 5
    Last Post: 01-12-2008, 03:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •