Results 1 to 2 of 2

Thread: Mega Drive issues (6-button pad related?)

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Strawberry (Level 2) Custom rank graphic
    FoxNtd's Avatar
    Join Date
    Mar 2010
    Thanks Thanks Given 
    Thanks Thanks Received 
    Thanked in
    4 Posts

    Question Mega Drive issues (6-button pad related?)

    Before I explain the issue let me describe my setup:

    JP Mega Drive model 1
    USA Genesis model 1 AC adapter
    USA Genesis 6-button controller and JP MD 3-button controller for testing
    (All games are JP MD, except for NHL 94)

    Overall I've seen no issues playing my games on my MD and with my controller... until recently when I got a few new titles.

    Forgotten Worlds is already a known issue, and is even listed on the MODE button explanation on the insert that comes in the box with the 6-button controller. I boot the MD with the MODE button held and I never yet had an issue playing this game.

    Next is Assault Suit Leynos. I literally thought my cart for this game was damaged or something. It will randomly reset itself. The behavior in the game mimics what happens when you die. Normally when you die you get "GAME OVER" then go to the main menu where you can use a continue, if you have any credits left. Well, when this unpredictable reset occurs, you don't see "GAME OVER" -- it just goes straight to the main menu as if I had died and I lost 1 credit.

    Tried booting the game holding the MODE button. Still experienced a reset. Later I tried to play with my 3-button. Did a run, got far in the game, no issues. Next run, made it to the end of the game, didn't win, no issues. Today, I played with the 3-button, made it far, HAD IT RESET, then was able to finish the game. The fact it reset with the 3-button attached has me very concerned. I've been skeptical about the AC adapter being an issue since the DC output is the same as the JP adapter anyway, though I'm still curious if anyone has a justifiable reason why I should import the Japanese adapter.

    I recently bought Dynamite Headdy, and during my first run, the game completely crashed. Screen freezes, controller does not respond, and a single tone, probably whatever note in the BGM was being played, is played continuously without end or change. Another attempt to play the game gave me the same thing. I got farther into the game but it still randomly crashed. That time, I booted holding MODE button.

    EDIT: Just played Dynamite Headdy with my 3-button. During the boss of stage 3 the game suddenly reset as if I hit the reset button. I think maybe 6-button controller can be ruled out with this test...

    My Mega Drive has never exhibited any other issues with any other game. Sonic, Gunstar Heroes, Puyopuyo, even the USA cartridge for NHL 94, I can play them as much as I want and no crashes or spontaneous resets. Shining Force is a long game and I played it start to finish with the 6-button controller, no issues whatsoever. So I'm sure it's got nothing to do with how long the Mega Drive has been on, I can play for 5 hours straight if I want.

    So what the hell is going on with Leynos and Headdy? Should I consider another Mega Drive? I still have my Genesis model 1, I could try the experiment of playing those games on that machine to see what happens. As long as they're not region locked (don't think they are) I can see what happens...

    I have tried but cannot find documentation about 6-button controller issues with either of these games. Only the usual suspects, Forgotten Worlds, Golden Axe II, etc.

    I might plug in the Genesis tomorrow to see if I can rule out the AC adapter and prove something is wrong with my Mega Drive.
    Last edited by FoxNtd; 11-16-2012 at 02:02 AM.

Similar Threads

  1. Replies: 2
    Last Post: 08-11-2013, 04:06 PM
  2. Japanese SEGA Mega Drive Multi Mega console (import CDX)
    By Black_Tiger in forum Buying and Selling
    Replies: 0
    Last Post: 02-03-2013, 12:22 PM
  3. Replies: 12
    Last Post: 12-09-2009, 06:35 PM
  4. Replies: 1
    Last Post: 06-21-2007, 06:18 PM
  5. SNES Controller Start button issues
    By youruglyclone in forum Technical and Restoration Society
    Replies: 1
    Last Post: 01-30-2007, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts