Results 1 to 4 of 4

Thread: Problematic consoles Iíve been trying to fix

  1. #1
    Insert Coin (Level 0)
    Join Date
    Aug 2020
    Posts
    2
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Problematic consoles Iíve been trying to fix

    Hello all! My name is Ricardo and Iíve been trying to get help on game systems that are problematic but canít seem to find the correct issue as to whatís going on with these systems.... I am not a hardcore collector but more of a repairman 👨*🔧 for computers electronics and video games and consoles. Iím very passionate about seeing older systems live longer so folks could get to enjoy them like we all did. I try my best to look up and research problems that Iím having before you make a thread. The following systems Iím trying to repair are

    1) a Model 2 Genesis, motherboard rev VA0. Games play and work fine, no graphical glitches.. just freezes.

    2) a SNES og model w the sound module. It turns on but no signal or audio whether RF or multi out. TV always says no signal as well.

    Please lemme know what I should do to approach these systems thanks.

  2. #2
    Alex (Level 15) Custom rank graphic
    Gameguy's Avatar
    Join Date
    Dec 2008
    Location
    Richmond Hill, Ontario (Canada)
    Posts
    7,503
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    44
    Thanked in
    38 Posts

    Default

    Quote Originally Posted by rfigueroa1288 View Post
    1) a Model 2 Genesis, motherboard rev VA0. Games play and work fine, no graphical glitches.. just freezes.
    Hi. Did you clean the cartridge connector and your games?

  3. #3
    Insert Coin (Level 0)
    Join Date
    Aug 2020
    Posts
    2
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by Gameguy View Post
    Hi. Did you clean the cartridge connector and your games?
    lol yeah when I first got it, it wasnít playing any games at all besides the mega everdrive so I took the board dunked it in 75% IPA, let it dry for a few hours and it was working fine but, now it freezes when trying to start retail cartridges and now the ED freezes during the main menu ad well

  4. #4
    Alex (Level 15) Custom rank graphic
    Gameguy's Avatar
    Join Date
    Dec 2008
    Location
    Richmond Hill, Ontario (Canada)
    Posts
    7,503
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    44
    Thanked in
    38 Posts

    Default

    It sounds like you didn't clean the cartridge connector properly based on the method you described, same with cleaning your game cartridges. There should be old cleaning kits that clean the cart slot, that's what I use. Methods on how to clean these should be searchable online.

Similar Threads

  1. Replies: 5
    Last Post: 02-24-2020, 04:58 AM
  2. Replies: 0
    Last Post: 07-09-2011, 04:50 PM
  3. Karma and The Problematic Customer [DP Store]
    By digitalpress in forum Classic Gaming
    Replies: 46
    Last Post: 07-17-2007, 08:23 AM
  4. PS3 Cell Processor fabrication is problematic says IBM
    By Bratwurst in forum Modern Gaming
    Replies: 16
    Last Post: 07-18-2006, 12:00 AM
  5. The most problematic game system you own?
    By sabre2922 in forum Classic Gaming
    Replies: 33
    Last Post: 05-17-2004, 07:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •